Chassis problems - Bracket Racing

Go Back  Bracket Racing > Racing > Tech
Reload this Page >

Chassis problems

Tech Racing Tech

Chassis problems

Reply

 
 
 
Old 12-03-2005, 09:57 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2005
Posts: 3
Chassis problems

I was scaling out a car today and have run across something that I have not had before. I was hoping that someone could give a little insite on it.
The car is a 70 Nova, 2x3 tube chassis ladderbar car. The car is new and only has 6 passes on it. It goes very straight. The main reason for weighing the car was to get the correct springs for the rear. Upon weighing it I have found that the car is 51% front and 49% rear. The rear corner weights are the same but on the front the right is lighter than the left. I have tried ajusting the preload on the rear, but that just throws everything out of wack. I set the rear back to where t was and ajusted the front springs to try and move weight from one side to the other. Still no good. The car launches had, goes striaght as an arrow. stops fine. Should I just leave it or maybe try adding a little weight to that side and see what happens. What do you think. I am open to ideas.
DonLee04 is offline  
Reply With Quote
Old 12-04-2005, 08:22 AM
  #2  
Junior Member
 
Join Date: Feb 2005
Location: W. Islip
Posts: 9
I'm no car builder but on the right side you have a steering box, column, pedal assembly and if a racecar the only seat. Hey, I took a shot I could be wrong.
Antisocial is offline  
Reply With Quote
Old 12-04-2005, 08:24 AM
  #3  
Junior Member
 
Join Date: Feb 2005
Location: W. Islip
Posts: 9
See, I was wrong, I ment the left.
Antisocial is offline  
Reply With Quote
Old 12-05-2005, 10:39 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Dec 2005
Posts: 3
Thats ok. Thanks for the shot. I set the car up equal on both rear, with the drive in place, and let the front fall where it may. I tested the car yesturday and it went straight as an arrow. Felt very solid, were before it had a little wiggle at the big end. Not even any pull while breaking. I don't know, something mayshow up when we start throwing more power at it. Time will tell I guess.
DonLee04 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mikelbeck
Tech
10
06-03-2005 05:40 PM
sickt7cuda
Tech
21
08-15-2004 11:21 PM
DARTSPORT
Tech
17
08-03-2004 03:30 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Chassis problems